Sie sind nicht angemeldet.

anthrax

Anfänger

  • »anthrax« ist der Autor dieses Themas

Beiträge: 15

Allianz: U-D-E

Wohnort: Emdöön

Beruf: Student

  • Nachricht senden
10

1

18.08.2008, 15:07

Darstellungsprobleme mit Browser Safari 3.1.2

Moin!
Ich nutze zum normalen Internetverkehr den Apple Browser Safari in der Version 3.1.2 auf meinem Mac. Hierbei kommt es häufig zu Fehldarstellungen im Spiel selbst. Teilweise hängt sich die Seite auf beim Laden, beim klicken eines Ingamelinks im Menü wird die Seite in einem neuen Fenster geöffnet (ohne dass das linke Menü mitgeladen wird), beim Laden der Seite wird häufig überhaupt kein Skin angezeigt oder nur geringfühgig etc.
An meiner Internetverbindung sollte es nicht liegen - 16.000er halt. Unter Firefox klappt es dahingegend einwandfrei, es wird teilweise sogar die nervige Werbung in den Pop-Up Fenstern unterdrückt.
Nun meine Frage: Hat sonst noch wer dieses Problem und vielleicht eine Lösung dafür parat?
Ich möchte nämlich zum einen nicht auf Firefox umsteigen, nur wegen Wog und zum anderen nervt es doch schon, in 2 Browsern zu arbeiten...
In den Sicherheitseinstellungen von Safari ist auf jedenfann nichts deaktiviert, was man brauchen könnte (Java, JavaScript etc.)

Wer also was weiss, bitte kurze Meldung und bitte kein rumgeflame von wegen "Nutz doch einfach Firefox, ist doch eh besser" oder "Im Internetexplorer tuts aber"!

Gruß,
Anthrax
Wer das liest ist doof.

2

18.08.2008, 15:09

vllt einfach mal den cache leeren, das bewirkt oft wunder.

oder benutzt du irgendwelche externen skins? welches skin benutzt du denn?

3

18.08.2008, 15:42

Komischerweise, habe ich dein Problem letztens beim Mac meines Vaters über Firefox erlebt und es ging wiederum mit Safari. Bin jetzt grade über Firefox drinne und alles läuft wieder, habe also zwar überhaupt keinen Plan wollte mit disem Post nur sagen, dass ich dieses Problem wie du es beschrieben hast auch kenne.

anthrax

Anfänger

  • »anthrax« ist der Autor dieses Themas

Beiträge: 15

Allianz: U-D-E

Wohnort: Emdöön

Beruf: Student

  • Nachricht senden
10

4

18.08.2008, 16:18

Also am Cache leeren liegt es nicht. Die Probleme sind nach wie vor da. Als Skin nutze ich zur Zeit den U-D-E Skin, der ja auf dem Spieleserver liegt. Aber egal welchen auswählbaren Skin ich nutze (Red, Blue - die wohl die wenigsten Anforderungen haben auch...) sind die Probleme gleich.
Wog sollte doch eigentlich modern genug programmiert sein, um wenigstens die vier "großen" Browser gleich mässig zu unterstützen. Das Seiten im IE anders als im Firefox oder im Safari oder in Opera angezeigt werden ist zwar nichts neues, aber sollte weitesgehend behoben werden können. Die Entwickler scheinen sich ja bei Wog auf HTML und CSS beschränkt zu haben, da sollten eigentlich keine grösseren Probleme als vereinzelte Fehler oder Fehlinterpretationen in der Bildschirmdarstellung vorkommen. Aber das beim klicken auf einen Spielinternen Link direkt ein neues Browserfenster geöffnet wird - mh - das ist mir echt neu und schleierhaft was die Progger da verbockt haben ;-)
Wer das liest ist doof.

5

18.08.2008, 16:23

Hmm, das wird eher mit den Browsersettings zusammenhängen als mit der Programmierung von Wog. Oben schreibst du, daß Pop-Up Werbung ausgeblendet wird, das kann schon ein Grund sein (ist im überigen bei Wog auch laut Agb verboten^^).


Wenn du glaubst ich atte nichtmehr,
kommt von irgendwo ne Ark daher!!!

anthrax

Anfänger

  • »anthrax« ist der Autor dieses Themas

Beiträge: 15

Allianz: U-D-E

Wohnort: Emdöön

Beruf: Student

  • Nachricht senden
10

6

18.08.2008, 16:50

Auch daran liegt es nicht. Zumal beim Safari die Werbefenster regelmässig auftauchen. Vom PopUp Blocker werden ansich, glaub ich, eh nur neue Browserfenster unterdrückt und eher seltener diese Browsereinternen Werbefensterchen...
Wer das liest ist doof.

7

18.08.2008, 16:58

also ich hab mir jetzt mal den quellcode des menüs etwas genauer angeschaut (vorweg, ich hab mit der programmierung hier nix am hut), aber das gesamte menü wird mit javascript aufgebaut. wenn der browser beim javascript irgendwas vermasselt, dann kann er die seiten nicht in dem frame "mainFrame" aufbauen.

hast du übrigens einfach mal versucht den safari neu zu installieren?

anthrax

Anfänger

  • »anthrax« ist der Autor dieses Themas

Beiträge: 15

Allianz: U-D-E

Wohnort: Emdöön

Beruf: Student

  • Nachricht senden
10

8

18.08.2008, 17:08

Hallo - ich hab nen Mac, da installier ich nix neu ;-)
Ne, hab ich nicht. Seh ich auch eigentlich nicht als Fehlerbehebung, da Wog die einzige, mir bekannte Internetanwendung aktuelle ist, mit der ich arbeite und die Probleme hat. Andere, auf JavaScript basierende Seiten funktionieren schliesslich auch fehlerfrei...

EDIT: Wow - ohne JavaScript-Aktivierung rockt Wog ja mal richtig die Kuh von der Weide *g*
Wer das liest ist doof.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »anthrax« (18.08.2008, 17:10)


9

18.08.2008, 17:12

mac hin oder her. der fehler scheint nunmal nur dort aufzutreten. sei es jetzt ein fehler im programm oder eine unkompatibilität mit dem code. wenn die navigation auf sämtlichen windowsbasierenden browsern funktioniert und dazu noch mit firefox auf mac funktioniert, dann frag ich mich wo der fehler liegen könnte.

schliesslich baut javascript lediglich den code auf. der code ist einfachstes HTML und da ist nichts falsch, außer safari kommt einfach nich so weit, dass target für den link zu erfassen. und irgendwas in der richtugn scheint mir der fall zu sein. warum auch immer.

anthrax

Anfänger

  • »anthrax« ist der Autor dieses Themas

Beiträge: 15

Allianz: U-D-E

Wohnort: Emdöön

Beruf: Student

  • Nachricht senden
10

10

18.08.2008, 17:23

Mmh, ich werd mich nachher mal schlau lesen und gucken, ob ich Präzedenzfälle über JavaScript bei Safari finde. Vermutlich ist es wieder eine ganz kleine Kleinigkeit, die da hakelt.
Wieso ist Wog eigentlich nicht komplett PHP-Basiert programmiert? PHP läuft ja nur auf dem Server und sollte, meiner Meinung nach, dadurch weniger Probleme bereiten, als JavaScript, das ja grundsätzlich auf dem eigenen Rechner rumrechnet. Und wenn man dann PHP und AJAX schön kombiniert wird eh alles fein dynamischer. Aber dafür ist, vermutlich, der Aufwand eines Relaunches zu groß...
Wie gesacht, ich werd später mal bischen rum suchen. Wenn ich was finde, werd ich es euch nicht vorenthalten...
Bis dahin muss Firefox mal her halten.
Wer das liest ist doof.

11

18.08.2008, 17:40

weil es nichtmal die client-PCs schaffen die uhrzeiten vernünftig anzuzeigen z.B. das willst du auf einen server verlagern? - dann kann keiner mehr spielen ;)

es gibt nunmal viele dinge die auf den client ausgelagert werden können und sollten.

javascript macht eh seit mehreren jahren kaumnoch probleme bei verschiedenen browsern und ist weitestgehend ausgereift.

das sich die seite abundzu aufhängt passiert auch abundzu beim firefox und ie. - liegt am teilweise unsauberen code, vermute ich.

und das sich die links in einem neuen fenster öffnen, haben andere dieselben probleme? ich kann mir kaum vorstellen das sonst noch einer dasselbe hat, weil es dann sicher schon solche "fehler"meldungen gegeben hätte... das du der erste bist mit safari glaube ich auch kaum ;) - also wird es vermutlich an einer deiner konfigurationen liegen.

anthrax

Anfänger

  • »anthrax« ist der Autor dieses Themas

Beiträge: 15

Allianz: U-D-E

Wohnort: Emdöön

Beruf: Student

  • Nachricht senden
10

12

18.08.2008, 18:29

Wie gesagt, die Safarieinstellungen sind ansich soweit OK. Kann man ja leider nicht so viel selbst einstellen wie beim Firefox. Aber auf anderen JavaScript Seiten habe ich halt keine Probleme. Najo, mal googlen gehn
Wer das liest ist doof.

Thema bewerten